Fatal error when twying to access Pawtucket installation

Hey everyone! I've followed the instructions for installing and configuring Pawtucket, and I'm running into the following error when I try to enter the website where it should be displayed:

Warning: require_once(/var/www/html/pawtucket/themes/custom/views/system/fatal_error_html.php): failed to open stream: No such file or directory in /var/www/html/pawtucket/app/helpers/errorHelpers.php on line 60

Fatal error: require_once(): Failed opening required '/var/www/html/pawtucket/themes/custom/views/system/fatal_error_html.php' (include_path='/var/www/html/pawtucket/vendor/pear/archive_tar:/var/www/html/pawtucket/vendor/pear/console_getopt:/var/www/html/pawtucket/vendor/pear/file_marc:/var/www/html/pawtucket/vendor/pear/pear-core-minimal/src:/var/www/html/pawtucket/vendor/pear/pear_exception:/var/www/html/pawtucket/app/lib:/var/www/html/pawtucket/app/models:.:/usr/share/php') in /var/www/html/pawtucket/app/helpers/errorHelpers.php on line 60

Not sure what could be causing it to not find the files or directories, since they are there. The way I have it set up is one folder for providence and one for pawtucket inside of the html folder, but these two are separate and not nested. Does it have to do with something about the pathing in setup.php? If it would be of help I can attach it here.

Please do let me know if I can attach anything else to clarify. Thank you in advance.


  • Have you created your own theme called custom? Did you copy another theme or created it from scratch?

  • Hi Monica! I copied the folder directly as it was from the Git repository. My apologies for the delay in replying, I never got a notification from this. I created no folders or modified anything in the installation.

  • So this is still happening, with the same error?

    What branch from github are you using?

    In your webservice configuration, what is the root path? If you haven't changed anything there, then I am guessing this is at https://youdomain.com/pawtucket for the pawtucket install and https://yourdomain.com/providence for the providence install. Are you trying to open the /pawtucket one when you are given this error?

    You also say you copied it directly and don't have a theme called custom? Because this is looking in the theme directory for a theme called 'custom' You should check your pawtucket setup.php for the theme settings.

  • Dearest Monica! This seems to have fixed it, my apologies for the dumb oversight. I changed it to "default" and after some wrangling I managed to get it going. Thanks a bunch for the assistance!

Sign In or Register to comment.