ACCESS DENIED error instead of login page

I am in the process of moving CA & PA to a new shared server (good ridden

Now when I follow a link to a CA page and I am not logged in, instead of pushing the login page with a forward back to the page, it just throws an error:

Access denied in /home/pelham10/public_html/ca/app/lib/Controller/AppController.php line 122:

Any thoughts




  • CA doesn't always work on shared servers.

    Have you been able to configure php correctly?

    Can you get to the homepage or to a Pawtucket page without error?

    What branch are you on and what version of PHP is the shared server using?

    Can you check logs to see more information?

  • it has been running fine for years on my old server. New server is the same version: git/develop. running php 7.4

    Once I am logged in everything is fine. It just doesn't auto forward to the login page when I am not logged in.

    If I go to the top page, it is OK....problem is only following links to an editor when not logged in.

  • Check logs to make sure there is no extra detail to the error.

    The bit of code that is throwing that error is this block here

    Check configuration to make sure all plugins are ok?

    Another thing to check is if you have clean_urls turned on in your setup.php? Are you using the same domain name and webroot for this new server?

  • solved...kind of user error. I happened to notice that index.php on my server was a different filesize than the git version. Not sure when/why but case solved...

    .... But I would like to add that error messaging does have room for improvement

Sign In or Register to comment.