Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Identifiers disappearing on save

edited June 2014 in Troubleshooting
When we edit an object's metadata and save, the object identifier (idno) blanks out. Even if we replace the idno, it blanks out on save. In the database, the idno is also blank. 

The same thing happens when editing a collection's metadata. 

The object identifiers were populated with a batch-import of media, where the identifiers were set to be the filenames of the imported files. The collection identifiers were defined when creating each new collection. 

Any idea what's going on here? 


  • What does your multipart_id_numbering.conf look like?
  • File is attached (as .txt — .conf not allowed as attachment) 
  • You have some junk in the configuration. Is this intentional? Those <<<<<<< Updated upstream and >>>>>>> Stashed changes bits should not be in there.

     accession_type = {     
    type = LIST,
    <<<<<<< Updated upstream
    <<<<<<< Updated upstream
    values = [ART, BK, BRO, DOC, JJ, OBJ, OH, POS, PHO, RAP, TRN],
    values = [OH, BK, TRN],
    >>>>>>> Stashed changes
    values = [OH, BK, TRN],
    >>>>>>> Stashed changes
    default = OH,
    width = 6,
    description = _(Object type),
    editable = 1
  • Thanks — will take a look. But in the meantime, the solution has presented itself as upgrading Providence to 1.4, where the issue (at least on our dev server) seems to resolve. 
  • Same problem with 
    Application version1.7.6
    Schema revision153
    Release typeRELEASE
    System GUID2898bdfc-702e-4705-a7cf-5b14e0e69646
    Last change log ID189876
    Before upgrading it worked fine (without any change on idno).
    Attached is my multipart_id_numbering.conf file.
    Any suggestion?

    Thank you,


  • I have the same problem with Providence 1.7.8

  • @gbenigni You have the line "ca_objects = {" commented out when you need it in there.
    @dongtruong Make sure your file is syntactically complete.

  • Thank you @seth
    It works now. My file multipart_id_numbering.conf was in wrong format.

Sign In or Register to comment.