Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Upgrade from Providence 1.6.1 to 1.7.5

I am trying to upgrade from Providence 1.6.1 schema revision 126 To 1.7.5.

I have downloaded the application (Providence) and database from our shared web server onto my Windows 10 laptop to do the upgrade within an XAMPP environment. I noticed the app/tmp files were very large, can I delete them and is there any way to limit the maximum size?

The downloads worked fine on the laptop, I then tried replacing Providence 1.6.1.with 1.75 and running the database update from the startup screen which indicated starting with migration # 127 as expected. I clicked for automatic update, it failed, uncaught fatal error message.

When I tried to go into the application again the startup screen stated starting with migration #130. I clicked for automatic update and again it failed, uncaught fatal error message. Launching the application again showed starting with migration #130. What is the schema for 1.7.5?

Please advise how to progress with the schema updates.


  • Hi there,

    What is the fatal error that you're seeing when you try to upgrade?

  • See attached screen shot.
  • Please check the log file, it will be in your Providence directory in app/log. There should be an ERROR line in the most recent log file that details what happened.

  • Here is the ERROR line from app/log

    2017-10-11 4:19:05 - ERROR --> DatabaseException: Can't DROP 'fk_ca_batch_log_items_batch_id'; check that column/key exists

    How can I resolve the issue?

  • Here is a screen print from phpmyadmin
  • Does anyone have any suggestions how I can solve my problem?
  • Open up the file support/sql/migrations/130.sql and comment out line 9 but prepending a "#" to it. Eg. change this:

    ALTER TABLE ca_batch_log_items DROP FOREIGN KEY fk_ca_batch_log_items_batch_id;

    to this:

    #ALTER TABLE ca_batch_log_items DROP FOREIGN KEY fk_ca_batch_log_items_batch_id;

    Then try to re-run the update.
  • Thank you for your your assistance.

    I commented our the line as suggested and re-ran the full upgrade. After some time another failure, but now when I went into the application the startup screen stated
    'starting with migration #133'. I clicked for automatic update and it failed immediately.

    app/log record

    2017-10-15 6:39:18 - ERROR --> DatabaseException: Duplicate column name 'circulation_status_id'
    2017-10-15 6:39:56 - ERROR --> DatabaseException: Duplicate column name 'circulation_status_id'

    Next step please.

  • I commented out a line from support/sql/migrations/133.sql

    #ALTER TABLE ca_objects ADD  `circulation_status_id` INT UNSIGNED NU

    Re-ran the update which completed.

    I have attached a screen print of the configuration check. Which seems to confirms the upgrade to 1.7.5

    Would commenting out the line from support/sql/migrations/133.sql have caused any problems?

  • It won't cause any problems unless you reload a different database and need to update that through migration 133. 
    These failures indicate that you may have tried to unsuccessfully update this install before?
  • Sounds right to me. Thank you.
Sign In or Register to comment.