Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Pawtucket Media Viewer Not Generating Images

Hi All -

I am perplexed by this issue, so I'm hoping someone else has come across it before. From Providence my media viewer works fine and generates the appropriate images, but from Pawtucket, if you click on a media item, like this example attached, all you see is a loading icon in the main screen, and warning icons in the thumbnails screen. Is there something I am missing with the set up of Pawtucket?



  • Hi there,

    This may not be the issue, but double check to be sure that the media is set to be publicly accessible. If you've got the object set to be available and the media set to be protected this can happen.

  • Hi Mike - This happens with everything (no matter the type of object), and both through the Admin Screen and the Media screen I have set the object and the media itself to Accessible to Public.
  • I should also mention that I am running the latest versions of both Providence and Pawtucket.
  • Here are some of the things that have popped up in the console, I have attached the whole file of what I copied from the console. Hopefully someone here can see what the issue might be. Thanks! Matt

    [Viewport.setHomeBounds] bounds.height must be greater than 0  openseadragon.js:16380:9
    [Viewport.setHomeBounds] bounds.height must be greater than 0  openseadragon.js:16380:9
    Error in parsing value for ‘top’.  Declaration dropped. app.html
    Error in parsing value for ‘left’.  Declaration dropped. app.html
    Error in parsing value for ‘width’.  Declaration dropped. app.html
    Error in parsing value for ‘height’.  Declaration dropped. app.html
  • edited September 2017
    This happens for me as well on detail pages, without having made any changes to media presentation, so it's definitely a bug. Should I switch to a different viewer?

    I see the same problem if I comment out this line in media_display.conf:

    use_mirador_for_image_list_length_at_least = 3
  • I am having this issue in Pawtucket as well, and a similar but not identical issue in Providence. When I try to load media, I get also get a pop up window just reading "Not Found" -- do you see this as well?
  • Liza, as well as bhoggard, I'll check when I'm back in the office. Out of curiosity, could you post a screenshot of your configuration? I have a feeling we're all dealing with a problem with similar origins (if not the same problem) and I'd like to compare your configuration to mine (I'll end up posting it as well when I get back). This is an incredibly frustrating issue as every report seems to lead me in a different direction.
  • The file is too big for a screenshot. I only changed that one line. Here it is as a gist:

  • I'm having the same issue.  I posted it in this thread a while back.  I can use Mirador and Universal View fine in Providence, but it doesn't work in Pawtucket.  I'm seeing the same Viewport.setHomeBounds issue.  Thanks!
  • Hello,

    this is a late late answer, but I've met the same error, I personally switched the viewer inside themes/default/conf/media_display.conf, modifying around L. 153 :

    media_overlay = {
    images = {
    mimetypes = {image/gif, image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, image/jp2, image/x-adobe-dng, image/x-dcraw, application/dicom},
    display_version = tilepic,
    alt_display_version = large,
    viewer_width = 100%, viewer_height = 100%,
    download_version = original,
    viewer = TileViewer

  • edited May 2018
    Same here, Universal Viewer takes ages to load a image. But TileViewer has severe mobile issues, no pinch zoom and touch move, messed layout. TileViewer also isn't developed anymore.

    edit: also tried Mirador with no luck, no image. I would love to use Mirador because its based on openseadragon and has a comparision feature. I really wonder why many of us cant get UniversalViewer and Mirador get working in Pawtucket 2. I think this is critical.

    edit2: I wonder if this all goes back to tilepic and if a switch to e.g. dzi format would be a path to go. But I'm no expert and maybe wrong.
  • edited May 2018
    I really would like to get on the bottom of this. Here is a Pawtucket2 front end with Mirador activated:

    But the detail page shows no image. Is it possible to analyze what is going on while Mirador loads?

    Alternatively I could give my host login to a dev if it would help to find the cause. Everything else works like a charm on this shared web hoster. Pawtuckets media folder is symlinked to providence. Mirador works in Providence!!

    I attach a image of firefox network analysis which stops at info.json.  In providence right after info.json the tilepic jpgs are loading, but the adress is the same:

    comparing the jsons I see additional quotation marks on SOME image width and height in the frontend json - may this be the problem?

    Thx for looking into this,
  • I have a solid 1.6.1 running. On a dev server, I am running the newest 1.7.6 with Centos 7, PHP 7.2, MariaDB 10.0.34.

    I have the same issues. Providence works perfect, Pawtucket, seems like it times out, or a limit.

    If I have a PDF with one page, it works, multi pages does not show.

    Be nice to move to a supported PHP. Main reason why I am looking to upgrade.
  • edited May 2018
    This is so weird, suddenly after dozen of tries the image appears and when it does it appears on all browsers on the SAME machine. As if once it found the way to display it it finds it always.

    But still, other images are not showing like this :

    What a mystery...

    edit: UV sometimes works randomly and after extremely long loading times. Mirador never loads a image.
  • edited June 13

    For anyone this may help. I had similar issues to the previous posts where images showed fine in Providence but not Pawtucket. I tried Gautier's fix for the IIIFService.php linked above. That didn't help me. However, I copied the IIIFService.php from Providence and moved that to Pawtucket, overwriting the original file. Then, images show ok using UniversalViewer

Sign In or Register to comment.