Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Providence Installer hiccup: "have you already installed collective access?"

Has anyone else experienced this? :
You start the installation process, select profile to load, it hangs up, then on second try it seems to be working, then you get this error:

There were errors loading the database schema: Table ca_locales already exists; have you already installed CollectiveAccess?

How can I get past this and complete the installation?
Screenshot attached.


[I’m running CA on localhost, MacOS HighSierra 10.13.6, Safari 12.01, Php 7.1, MySql 8.0]


  • In setup.php, change the following setting from 'false' to 'true':


    After you have successfully installed a profile, be sure to set it back to false.

  • Thanks! I tried it and got this error below the loading schema:

    Fatal error: Uncaught DatabaseException: Error dropping database (can't rmdir './casfom_test01/', errno: 17 - File exists)

    Permissions issue somewhere?

  • An update - I figured out how to rm the database manually since allowing the overwrite option on install didn't work. I was able to get further in the schema loading, and can see tables created in my test database but have been now confronted with the following errors while "Installing database table for list items" :

    Fatal error: Uncaught DatabaseException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'rank int unsigned not null default 0, ' at line 11 in /Users/xxx/sites/providence/app/lib/core/Db/mysqli.php on line 316

    I don't know where to look for line 11 referenced above; definitely not in the mysqli.php doc. Where is the Sql syntax error coming from? A script that is creating the tables?
    Thanks again to anyone reading or with suggestions.

  • We don't yet support Mysql 8.0. Try running Mysql 5.x.

  • I uninstalled mysql 8 and installed/switched to vs.5.7. After many more errors and troubleshooting and recreating the test database and user, the installer finally worked and I have CA up and running.

Sign In or Register to comment.