Problem with Providence lightbox

In Providence, when accessing an enlarged image in the Lightbox overlay, the initial enlarged images presents itself fine. However when zooming in and panning around for an even larger detail, an error is thrown, “an error occurred when trying to access /providence/index.php/Detail/GetMediaOverlay/context/id/167/representation_id/363/overlay/1: Invalid controller path." The image disappears and is replaced by a path presumably for the detail image more enlarged. Any ideas why this is happening? Thanks!



  • I am running into the exactly same problem. Debian 9, providence 1.7.6, git commit a358ebbd.
    Lightbox was working in the past (before summer?), but I cannot specify which system update or git checkout caused this issue. Any clue on your side, rsteinert?

  • Hi Felix -- Since it is on the data entry side, I am living with it....Not ideal. Will post any findings I have when I get some time to investigate.

  • Any updates here? We are running into the same issue.

  • In your media_display.conf file check the "images" blocks and make sure no_overlay = 1 is set. Eg:

    images = {
    mimetypes = {image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, image/jp2, image/x-adobe-dng, image/bmp, image/x-bmp},
    display_version = medium,
    alt_display_version = medium,
    viewer_width = 100%, viewer_height = 100%,
    ** no_overlay = 1,**
    use_universal_viewer_for_image_list_length_at_least = 12,
    download_version = original,

        viewer = TileViewer
  • OMG super fast @seth! Thanks! I'll try this.

    I just went in and changed the images to use the UniversalViewer instead of TileViewer, and that also solved the problem.

  • Thank you, Seth! That is great! Works really nicely. Will this setting be preserved when upgrading Providence or should we make a note of it to change manually?

  • It will be preserved when upgrading.

  • Seth, it seems that TileViewer is no mor working on v 1.7.7.

  • Works for me. You'll have to be more specific.

  • Here the details: Mirador and Universal viewers work fine. TileViewer loads but does not load the image.
    The media_display.conf is the original delivered withg v. 1.7.7 apart from switching from UniversalViewer to Mirador.

    media_overlay = {
    images = {
    mimetypes = {image/gif, image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, image/jp2, image/x-adobe-dng, image/x-dcraw, application/dicom, image/bmp, image/x-bmp},
    display_version = tilepic,
    alt_display_version = large,
    viewer_width = 100%, viewer_height = 100%,
    download_version = original,
    no_overlay = 1,

        viewer = Mirador,
        #use_universal_viewer_for_image_list_length_at_least = 3
        #use_mirador_for_image_list_length_at_least = 3
  • Maybe v. 1.7.7 misses some code you get from previous versions?

  • Same for me, I have 1.7.6, 1.7.7 and 1.7.8 on the same server with the same setup.conf and same media folder linked by a symbolic link:

    1.7.6 work with TileViewer and the param overlay =1 mentioned above

    1.7.7 and 1.7.8 no, they work just with UniversalViewer or Mirador enabled,
    TileViewer won't display any image here

  • The tile server relies on some server environment variables that apparently are not present on all systems. There's a patch for this:

    You can apply this to your tile server code in views/apps/tilepic.php or wait for the next release.

  • Does not work for me. Where exactly should $media_root and $media_path point to?

  • edited May 2019

    Finally, I solved by hard setting the variables this way in /apps/tilepic.php:
    $media_root = "/var/www/html/providence/media/mvca/";
    $script_path = "/providence/media/mvca/";

  • edited May 2019

    This is better and not "hard":
    $media_root = CA_BASE_DIR."/media/".CA_APP_NAME."/";
    $script_path = substr(CA_BASE_DIR,strrpos(CA_BASE_DIR,"/"))."/media/".CA_APP_NAME."/";

    But I'm having some troubles because of "/"... I'm working to fix it.

  • edited May 2019
  • having this issue in pawtucket2 1.7.8. tried the patch and also the hardcoded variables in /pawtucket/viewers/apps/tilepic.php but neither worked. tileviewer works fine in providence.

    any other ideas are greatly appreciated

  • Lightboxes dont work in Pawtucket2 1.7.9 and 1.7.10. Its impossible to create one. Nevertheless it was possible in Version 1.7.8 and it's still with Lightboxes that already exist.

  • I have the same issue.

    Existing lightboxes work in Pawtucket 1.7.11. User can add objects.

    Users are not able to create a new lightbox inside Pawtucket.

    A new user lightbox can be created inside Providence 1.7.11 and is then available inside Pawtucket.

  • It seems like rebuilding the search index with caUtils did it for me.

    I observed the same issue on our test server with Providence 1.7.9. After rebuilding the search index it worked well. Unfortunately our database is very huge so I couldn't tell anything about Providence Version 1.7.11 yet.

  • What happens when you create a new lightbox? It simply doesn't appear in the user's list? Or is there an error?

  • When i try on my local (WAMP Server) installation I get this error:

     Fatal error: Uncaught Error: Call to a member function purify() on null in F:\wamp64\www\CA1711_RB\pawtucket\app\controllers\LightboxController.php on line 1149

  • What about on your actual server?

  • On the actual server in my testsystem (that you have access to) I get:

    Fatal error: Uncaught Error: Call to a member function purify() on null in /home/u31667p26800/domains/ Stack trace: #0 /home/u31667p26800/domains/ LightboxController->ajaxAddItem(NULL) #1 /home/u31667p26800/domains/ RequestDispatcher->dispatch(Array) #2 /home/u31667p26800/domains/ AppController->dispatch(true) #3 {main} thrown in /home/u31667p26800/domains/ on line 1149

  • Ok thanks. I will look into this today. I feel another release coming on :-/

  • I see the problem. There's a fix for it in GitHub "master". Please give it a try when you can and let me know if it works ok for you.

  • Thats it. With the new files it works well for me. Its possible to create Lightboxes again.

  • Excellent. I'll wait for Remco to weight in. If it's ok for him then I will pack it up into an updated release. Thanks for taking the time to try it.

  • We have major issues with searching. I can't figure out if the patch was the deal. But anyway we turned back to CA 1.7.9.

Sign In or Register to comment.