Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Exported Configuration File seems to get corrupted

I had a problem in Providence Ver 1.7.8 with Export Configuration File and have just installed Ver 1.7.9 to see if If the same problem exists and it appears that it does.
If I try and do an install with my exported Configuration File it gives the error that the file is not a valid XML file.
If I then VALIDATE the Exported Config file through XML COPY EDITOR using the profile.xsd I get the following error
ERROR at line 43, column 29: no declaration found for element_ 'description'_
If I delete this line and run the process again I get the same error at line 47.

I then do a find_ 'description' _and replace with** "'"** and I end up with 17814 replacements, (I have a large Configuration File)
After again running XML COPY EDITOR - VALIDATE results in collectiveaccess_config.xml is valid.
The modified file is accepted by the Providence installer.
I am not sure if I am doing something wrong . Any suggestions for fixing this?


  • Post the output here please?

  • Hi Seth,
    Not sure which output you want - so I have posted a screen shot of the first lines of the output of the XML copy editor.
    At the bottom of the screen it states -
    Error at line 43, column 29: no declaration found for element 'description'
    If I delete this line and then run XML Copy again it stops at line 48 with the same error and so on through the whole file.
    Hope this helps!

  • How are you validating this? Are you sure you're using the most current profile.xsd?

  • Hi Seth, After reading your response I realised the error of my ways and beg for mercy :# I was using an outdated profile.xsd. Using the latest version the config file is flagged as valid. My question then is - can the latest profile.xsd be used to validate a config file from an earlier version of providence that may have an earlier version of profile.xsd.
    Thank you for your patience.

Sign In or Register to comment.