Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Searching by Dates

Hi All,

Wondering about searching by date and date range in CollectiveAccess.

I've created several objects - each of which has a 'Date Created'.

Under 'Manage' -> 'Search Tools' - I've created a new advanced search form, and added Object Date to the form (as well as Title and Full Text).

However, it doesn't seem to matter what I enter in the advanced search form date field - I'm unable to retrieve my objects by date. Does the date have to be exact? And is there any method by which a range could be searched for? For example show me all the objects created between March 1964 and April 1964?

Am I missing something in my configuration - like including the object date field in the full text configuration file?

Thoughts?

Comments

  • Here is some documentation about search syntax, including searching on dates and ranges: http://docs.collectiveaccess.org/wiki/Search_Syntax#Searching_on_dates

    Make sure that the field you put on your advanced search form is the same as is used on your Object record and not another date field from elsewhere in the configuration.  You can do this by checking the element code underneath the field name (on both the Search tools screen and the User interface screen).
  • I have been following the instructions on the search syntax wiki page, but am having a similar problem. Only exact dates are being retrieved, and ranges are not working at all. Using an asterisk as a wildcard works in the basic search but not in the advance search for dates. Does anyone have a fix for this?

  • May be a silly question, but are you sure the datatype for the field is DateRange?

  • @devonhayley Can you provide an example of a date search that you think should work but doesn't?

  • @seth I don't know what I did but this problem seemed to resolve itself and the system is now letting me search by date ranges.

Sign In or Register to comment.