Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

install stuck

edited August 13 in Installation


new to CA and would like to use it to archive an artists lifetime work.

I followed all steps for installing CA on a hosting platform (Hostmonster), but during the install the process is stuck at processing user interfaces.

i tried 2 times already, but no luck.

if i open the login, i am asked for the credentials, but whatever i use, no luck.

error log only gives this

[13-Aug-2020 14:42:53 Europe/Berlin] PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home3/atelierk/public_html/katalog/app/helpers/utilityHelpers.php on line 3883

and the same for 20 or more files



  • actually, install is getting stuck all the time, not at a special point, just not reaching the screen with login information.
    is the login infos stored somewhere to test login, as i can see the login screen when openning the url.


  • It could be just about anything. Maybe try a different host.

  • janjan
    edited August 13

    i cannot really try a new host, already paying this one a lot, but i can see all the tables being created, at least i think they are and no error messages in log.
    i have 224 tables on the dublin core install.

  • What version of CA are you using? And what version of PHP is the server running? Also, what version of MySQL is running?

  • CA is 1.7.8,

    Web server
    Database client version: libmysql - 5.6.43
    PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
    PHP version: 7.3.6

  • janjan
    edited August 13

    like i said i can access the login screen, but i didn't get to the login info, so now i cannot access.
    is this info stored somewhere?

    only error i get is:

    [13-Aug-2020 17:48:19 Europe/Berlin] PHP Warning: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages:
    error:1409442E:SSL routines:ssl3_read_bytes:tlsv1 alert protocol version in /home3/atelierk/public_html/katalog/app/lib/Controller/Request/RequestHTTP.php on line 660
    [13-Aug-2020 17:48:19 Europe/Berlin] PHP Warning: fsockopen(): Failed to enable crypto in /home3/atelierk/public_html/katalog/app/lib/Controller/Request/RequestHTTP.php on line 660
    [13-Aug-2020 17:48:19 Europe/Berlin] PHP Warning: fsockopen(): unable to connect to tls:// (Unknown error) in /home3/atelierk/public_html/katalog/app/lib/Controller/Request/RequestHTTP.php on line 660

  • Can you SSH into the server?

    I believe the default user in Dublin Core install is simply "administrator", so if you go to the [server]/[providence]/support you can run

    sudo bin/caUtils reset-password

    to change the password so that you can log in. I have made the mistake to go too quickly through this process, so I do not realize which prompt is asking for the sudo password and which prompt is asking for a new password, so just be on the look out for this detail.

  • janjan
    edited August 14

    hi sjenson,
    thx for helping.

    i tried that but get this error message

    sudo: effective uid is not 0, is /usr/bin/sudo on a file system with the 'nosuid' option set or an NFS file system without root privileges?

    checked with hosting service and in shared hosting there is no root access, damn.

    any other way of solving this?

    would hate to not use AC, looks really amazing for what i need.

  • i also tried this out

    UPDATE ca_users SET password = md5('mynewpassword') WHERE user_name = 'administrator'

    but the table is empty.

Sign In or Register to comment.