error in system configuration detected

I followed the instructions for the installation of Pawtucket step by step.
Pawtucket is on my domain in /ca/pawtucket.
I set the symbolic link (ln -s /ca/media ~/ and gave the media folder the 777 privileges.
But I still get the following error message "It looks like the media directory is not writable by the webserver. Please change the permissions of / (or create it if it doesn't exist already) and enable the user which runs the webserver to write this directory".
I went through the forum, but the only tips I found are about the symbolic link and the writing privileges.

Has anyone got a tip on how to solve the error? Thanks very much in advance.



  • In the Providence setup.php file, did you rename the application? Here is the line in question:

    if (!defined("CA_APP_NAME")) {
    define("CA_APP_NAME", "collectiveaccess");

    If you did, I believe you will need to change the app name in the Pawtucket2 setup.php to match.

    Another option, perhaps a more likely one, is that I have forgotten a few times to set the 777 privileges to be recursive in the media folder, so the folders inside not fully writable.

  • Thank you! The app name in the setup.php file was indeed wrong.

  • I'm still looking for a solution!
    The CA_APP_Name is "collecetiveaccess" (my last comment was wrong).
    I set the 777 priviliges again with filezilla and checked it, that can't be the reason for the quoted error message.
    I have to ask again, if anyone has got a tip on how to solve the error? Thanks very much in advance.

  • I'd check the CA_BASE_DIR path. Otherwise I couldn't say without looking at the machine.

  • Thank you Seth, problem solved!
    In "global.conf" the "ca_media_root_dir" path was wrong. I can't remember why I changed it in the first place, but it works now with the right absolute path.

Sign In or Register to comment.