Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Upload importer (drag-n-drop) never finishes

I'm trying to upload an importer mapping worksheet using the drag-and-drop function in the "import > data > add importers".
When I drop a .xlsx File onto the region, a progress bar is shown - then 100% and the filesize of the worksheet file - but then nothing happens.

The mapping also does not show up in the importers list.
I've tried with 2 different installation: v1.7.8 and v1.7.9 (develop branch)

When I add the mapping using the commandline tools, it works just fine.
How can I fix/use the GUI option?


  • I remember having a similar problem of the importer stopping at the end which was solved by installing php-zip; however, as I never tried to use the command line tool to run the import.

  • @sjenson: Thanks for the tip, but I've checked now and I've got php-zip installed.
    I've solved it: The "memory_limit" in php.ini was too low (256M) - I've set it to 512M, and it works fine now.

    Here's the error message in the Apache logs that helped:

    [:error] [pid 2248] [client] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 16777216 bytes) in /var/www/html/providence/vendor/phpoffice/phpexcel/Classes/PHPExcel/Worksheet/RowIterator.php on line 145, referer: http://XXXXX/providence/index.php/batch/MetadataImport/Index
    zend_mm_heap corrupted

    Case closed :wink: :sunglasses:

Sign In or Register to comment.