Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Geocode field is not working


Just wanted to test Google Maps integration in the software, so i subscribed to Geocoding and Maps JavaScript API. I made an API key for authentication, restricted to these 2 services.
Pasted the key into setup.php, installed CA with my installation profile and made a geocode metadata field which i had attached to a UI > Screen.

The field itself looks like this (it also crops the content when i try to zoom in-out):

And when i want to save the record, i get this error message:

I'm not getting any error from the API in the console.

Do you have any suggestion what could be the problem?

Thanks in advance!


  • You'll need a GoogleMaps key for Geocoding to work. It will have to be set in setup.php.

    You may also want to try a different tileserver than the default. In app.conf set

    leaflet_base_layer = https://{s}{z}/{x}/{y}.png

    It might help.

  • Hi seth!

    Thanks for your reply!

    Already have the key (mentioned above), enabled the corresponding APIs (Geocoding and Maps JavaScript)

    I pasted the key in setup.php:

    if (!defined("__CA_GOOGLE_MAPS_KEY__")) {
      define("__CA_GOOGLE_MAPS_KEY__", "MY_API_KEY");

    Still getting the same error.

    I'll try to change the tileserver, thanks for that.

  • 224224
    edited October 9

    Hi @seth !

    Tried to change the tileserver, but with no luck:

    And still getting the same error after saving the record.

    Any tips?


  • No idea then. This works for me when I test it.

Sign In or Register to comment.