Pawtucket Image Viewer not loading

Hello -

I just upgraded Providence to 1.7.14 (from 1.6.x), and installed Pawtucket2 1.7.13. Providence is working great, but the image viewer in Pawtucket is blank. The smaller previews are fine, and I can download the full-size image. ~/www/providence/pawtucket/app/tmp is being written to on every page load.

I'm on a shared host, running Linux 3.10, PHP 7.4, with Imagik being used by Providence. RAW isn't supported, but all of my uploads are JPEG.

Any pointers would be greatly appreciated.




  • Since you're migrating from 1.6 you'll need to reprocess all of your media to ensure usable media previews used by viewers are available. Have you reprocessed your media using the caUtils command-line utility? From the support directory the command would be bin/caUtils reprocess-media

  • Hey thanks Seth - I just tried running that, and it only makes it through one file, then quits. I had assumed the images were OK though, since they work with the tilepic viewer in Providence, which appears to be the same as the one in Pawtucket?

  • Images should work without reprocessing. Documents (eg. PDFs, Word docs) won't. If all you have are images, then maybe something else is going on. Can you send me a link to the Pawtucket site so I can take a look?

  • Ah, good to know - It's all just images for now.

    should caUtils reprocess-media have made it through all of the image files anyway? Just trying to figure out if there's something else going on with my config or hosting. It says there's a few hours remaining, then just ends after 1 or 2 images (always the same one or two).


  • Yes, it should get through all of them. There should be an error if it's failing. Make sure PHP "display_errors" is set to "On"; also on some servers I've noticed that MySQL-related memory errors can cause the script to die silently. So that's something to look at, perhaps.

  • So looking at your site, it looks like that paths for the tilepics are incorrect. Did you symlink the Pawtucket media directory to the Providence one? Or else how did you give Pawtucket access to the media?

  • hmm.. yes, there's a symlink between pawtucket/media and media. I realized all of the various media files are in providence/media/collectiveaccess - should I be symlinking to media/collectiveaccess instead?

  • Either one should work. I have another idea – I will investigate and post again soon.

  • thanks! That caUtils issue ended up being an SQL server timeout - my provider fixed it, and it's running now (didn't fix the tilepic issue though)

  • If it helps, linking to media/collectiveaccess did not work - loading the site throws the error that the media directory is not writable.

  • edited February 2022

    @PaulC Any luck? I run into the same issue and I am on version 1.7.13.

  • Sorry for dropping this... will have some insights in the next day.

  • Are either of you running Imagick with your installs? If not, are you running Gmagick or GD?

  • Hey Seth -thanks for jumping back into this. Yes, running Imagick.

  • Can you pull down the current "master" branch for Pawtucket2 on GitHub and try it out? There's a modification in there that should resolve the issue

  • Was it just the change to /app/lib/plugins/media/Imagik.php? I didn't replace the whole branch, but replaced that file, and the issue still persists. Is there anything I'd have to 'restart' beyond just clearing cache and loading the page?

    There's a different image viewer that comes up whenever I select an object that has 4 or more images, and that one doesn't work either.

    It seems I can enable gmagick from Cpanel - should I try that?

  • Clear out the cache (deleting the contents of app/tmp should help. And please do try running Gmagick. It'll help isolate the problem.

  • Gmagick didn't seem to change anything - sorry, is app/tmp on the client side or server side? I'm not seeing anything on the server side, and on the client side, I've tried clearing cache on chrome, and using Safari, which I never use - Firefox is my usual browser, on MacOS 10.14.6

  • app/tmp is on the server side, relative to the root of your install.

  • app/tmp cleared in both providence & pawtucket. Cache cleared on the client side. Sage burned. No change. sorry.

  • I see the problem now. It's specific to the nested directories you're using. The other stuff was a red herring. I'll have a fix on GitHub in a few minutes.

  • edited February 2022

    haha, OK! Sorry, should Pawtucket not be in Providence? I don't remember why I did that, but it 'seemed like a good idea at the time'. I'll get eyes on the fix in the morning. thanks so much!

  • There's an update to viewers/apps/tilepic.php in GitHub. Please try dropping that into your Pawtucket set up (or do a pull; which ever you prefer).

  • PS. I love your collection. I only have the one scope. I'm jealous.

  • woohoo! It works!

    So was I not supposed to put Pawtucket in Providence, or was it something else that was wonky about my install?

    Objects with 4 or more pics launch the other image browser, and that doesn't work - can I just always use the now working tilepic viewer for all objects?

    My scope collection is currently very underrepresented in CA ; it's mostly just the gauges. I have... a lot of Oscilloscopes (my IG toomanyoscilloscopes).

    thanks so much for your help!!

  • You should be able to put Pawtucket wherever you want. The issue was with how the directories were nested and should not be a problem – and isn't now. Thanks for raising the issue.

    The document viewer interface loads fine for me: I can see the scope and zoom. Still, that interface is really for documents. You might want to disabled it by editing the entry for images in media_display.conf (in your theme).

    I'll check out your instagram. My scope is a boring digital one. Maybe I'll get inspired to find a CRT.

  • I can't seem to shake that universal viewer...

    The image entry for both Detail & Image overlay has 'viewer = TileViewer', and use_universal_viewer_for_image_list_length_at_least = 4 is commented out (I tried cranking it up to 10 but still happened on anything with 4 or more).

    tmp files cleared.. anywhere else I should be looking?

  • You should make sure you're changing it in the conf file for the theme you're using, and change for all entries.

  • oh Riiiight, the in the theme. Thanks!!

  • Okay. My installation is 1.7.13. And I emptied the tmp folder, replaced Imagick.php in plugin folder with 2.0, replaced tilepic.php with 2.0. Still can't see the popup in lightbox. Any advice?

Sign In or Register to comment.